Home > Frequently Asked Questions > KitchenAid > My KitchenAid mixer runs at full speed only

My KitchenAid mixer runs at full speed only


Customer
wrote

I have a Kitchen Aid Mixer with a speed control problem. Runs at full speed only.

I see that speed sensor part number 9703312 is possibly at fault. Also, the speed control board in my unit is 9706508. Is this compatible with the units you sell? I believe this could also be at fault. My model number is KT2651XGR Epicurean.

Not sure if one or both of the above is bad.
Support
wrote

In order to determine which speed control will fit your mixer, I will need the serial number of your mixer as well.

Customer
wrote

Thanks for responding,

The model number is KT2651XGR . The part number on the existing speed
control is 9706508. That is the number that is check marked. There is
another number next to it. It is 9706509 which is not marked.
   Support wrote

Can you get the serial number of the Stand Mixer? It will be located on the bottom of the mixer and that way I can determine which speed control board you need. The numbers stamped on the board do not help us at all.
Customer
wrote

The serial number is WL4724964
Support
wrote
Your model fits in just after the change. Anything from date code WL46 and newer will use the same speed control board. The date code is just the first four digits of the serial number. So with that information I know you use the 4 wire+ribbon wire speed control which is still available.

I also need to know when the mixer is running at full speed does it shut off on it own? If it does then it is the sensor, if it just runs on high speed, but does not shut off on its own within 20 seconds it is the speed control board.

Here is a link to both of the parts that will fit your mixer.

Sensor/Ribbon Wire: http://www.mendingshed.com/9703312.html
4 Wire Speed Control Board (9706648): http://www.mendingshed.com/6qtspeed2.html
Please let me know if you have any other questions.